负载均衡BLB

    安装

    运行环境

    1. 运行环境 PHP SDK包要求运行环境至少为PHP 5.3.2 版本。
    2. 鉴权和认证 要使用百度智能云产品,您需要拥有一个百度智能云账号和一个有效的 AK(Access Key ID)、SK(Secret Access Key)用来进行签名认证。

      可以通过如下步骤获得并了解您的AK/SK信息:

      1. 注册百度智能云账号
      2. 创建AK/SK

    安装SDK

    1. 官方网站下载Java SDK压缩工具包。
    2. 解压ZIP包之后有三个文件,如下:
    BaiduBce.phar			//PHP SDK
    BlbClient.php	 	//示例
    SampleConf.php			//参考配置文件,具体内容见下文
    1. 在脚本文件中添加以下代码,即可以使用SDK包:
    include 'BaiduBce.phar';
    require 'YourConf.php';

    关于配置文件的引用请参考下文中的配置BlbClient。

    SDK目录结构

    BaiduBce.phar
    ├──src
    │   └── BaiduBce
    │       ├── Auth                //BCE签名相关
    │       ├── Exception           //BCE客户端的异常
    │       ├── Http                //BCE的Http通信相关
    │       ├── Log                 //BCE日志
    │       ├── Services
    │       │   └── Blb                   //BLB主目录,此目录必须保留
    │       │       ├── BlbClient.php     //BLB操作类,所有操作可以通过BlbClient类可以完成
    │       │       
    │       └── Util                //BCE公用工具
    └──vendor                       //第三方库

    卸载SDK

    预期卸载 SDK 时,删除脚本中include的phar包即可.

    上一篇
    概述
    下一篇
    初始化