安装SDK工具包

运行环境

PHP SDK包要求运行环境至少为PHP 5.3.2 版本。

安装SDK

  1. 官方网站下载BOS PHP SDK工具包(ZIP包)。

  2. 解压ZIP包之后有三个文件,如下:

    BaiduBce.phar            //PHP SDK
    BosClientSample.php         //示例
    SampleConf.php            //参考配置文件,具体内容见下文
    

    说明: 用户在配置好AK/SK和Host之后,可以使用phpunit --debug BosClientSample.php来运行Sample。

  3. 在脚本文件中添加以下代码,即可以使用SDK包:

    include 'BaiduBce.phar';
    require 'YourConf.php';
    

关于配置文件的引用请参考下文中的配置BosClient

SDK目录结构

BaiduBce.phar
├──src
│   └── BaiduBce
│       ├── Auth                //BCE签名相关
│       ├── Exception           //BCE客户端的异常
│       ├── Http                //BCE的Http通信相关
│       ├── Log                 //BCE日志
│       ├── Services
│       │   └── Bos                   //BOS主目录,此目录必须保留
│       │       ├── BosClient.php     //BOS操作类,所有操作可以通过BosClient类可以完成
│       │       ├── BosOptions.php    //BOS自定义配置
│       │       └── CannedAcl.php     //CannedAcl模块
│       └── Util                //BCE公用工具
└──vendor                       //第三方库

卸载SDK

预期卸载 SDK 时,删除脚本中include的phar包即可。