字、下划线组成 账号类型 普通账号 可以通过控制台或者SQL语句创建和管理 一个集群可以创建多个普通账号,具体的数量与集群内核有关 需要手动给普通账号授予特定数据库的权限 普通账号不能创建和管理其他账号,也不能断开其他账号的连接 密码 长度为8~32个字符,由字母、数字和特殊字符(!
根据数据库的类型(MySQL 5.7 或 MySQL 8.0),选择对应的参数模板,并点击 应用到集群 操作。 选择集群所在的地域并勾选对应的集群,在参数信息可以看到参数变化。 确认对所选择集群应用高性能模板。 方法二: 登录 GaiaDB 控制台 。 在 集群列表 找到目标集群,单击集群ID。 点击左侧列表中的 参数管理 。 点击 应用参数模板 。 在 模板名称 中选择系统高性能模板。
MySQL慢日志典型实践 概览 本文主要介绍慢日志明细和错误日志明细的使用方式。 需求场景 慢日志明细: 历史慢SQL实时统计,方便数据库管理员对慢查询语句进行分析,快速定位系统正在进行的性能问题。 错误日志明细: 开启和关闭MySQL服务的时间和服务运行中异常情况的统计,用于MySQL服务出现异常时,及时查找原因。
创建代理实例 GaiaDB数据库代理是位于数据库和应用程序之间的网络代理服务,用于代理应用程序访问数据库时的所有请求,具有高可用、高性能、可运维、简单易用等特点,支持读写分离、负载均衡、等高级功能。您可以连接GaiaDB集群地址使用数据库代理的各项功能。 前提条件 已创建GaiaDB集群。关于如何创建集群,请参见 创建集群 。 创建代理实例 登录 GaiaDB管理控制台 。
使用文档 本文档介绍百度智能云 GaiaDB 服务的 Java SDK 使用方法,涵盖客户端初始化及集群、接口、账号、数据库、快照备份、白名单、参数模板等全部功能接口。 目录 准备工作 集群管理 价格查询 连接接口管理 账号管理 数据库管理 快照与备份 白名单管理 参数管理 异常处理 准备工作 1.1 引入依赖 在项目中引入 bce-java-sdk 依赖(版本以实际发布为准)。
ot;allocatedStorageInGB": 5120, 11 "allocatedMemoryInMB": 8192, 12 "allocatedCpuInCore": 2, 13 "engine": "MySQL
暂停集群适用场景: 临时或长期停止使用数据库,但希望继续保留数据,以便随时启用。 先暂停集群以验证对业务无影响,再根据需要释放集群。 其它希望暂停集群的情况。 影响 暂停期间 所有 操作均会失效,包括连接、备份、变更配置等。 建议在 全量备份 后再进行暂停集群行为,避免关机后启动失败只能从备份集恢复的情况。 集群暂停期间,相关 集群地址、节点、热活集群组等资源 均处于暂停状态。
创建数据库 创建数据库 接口描述 本接口用于创建数据库。
删除数据库 删除数据库 接口描述 本接口用于删除数据库。
重启代理实例将导致短暂的连接中断 ,期间代理无法转发数据库请求。 读写集群地址 的服务节点必须包含主节点,且主节点不支持移出;只读集群地址的服务节点不包含主节点,不处理写请求。 规格变更 过程中,连接地址会出现 秒级连接闪断 ,建议在业务低谷期执行变更,并确保应用具备自动重连机制。 管理代理实例 登录 GaiaDB管理控制台 ,在集群列表中找到目标集群,进入 集群详情 页面。