重启节点 概述 GaiaDB 提供了重启节点功能,您可以在控制台上手动重启节点解决数据库连接和性能问题。 注意事项 重启节点将导致连接该节点的访问入口可能发生阻塞。重启节点的过程中,可能会出现连接闪断。建议您在业务低谷期执行重启节点操作并确保应用具备重连机制。 重启节点的时间长短跟您业务的数据量有关,可能需要几个小时,请谨慎操作。 集群状态为非运行中时,不支持重启节点操作。
使用JavaAPI连接 HBase Java API是HBase最常规和最高效的访问方式,Java客户端其实是shell客户端的一种实现,操作命令基本上也是shell客户端命令的一个映射,适合Hadoop MapReduce Job并行批处理 HBase表数据等场景。 建立完连接后,即可使用Java API访问HBase集群,下面提供一些简单的Java 示例。
需要手动给普通账号授予特定数据库的权限。 • 普通账号不能创建和管理其他账号,也不能断开其他账号的连接 密码 长度为8~32个字符。 由字母、数字和特殊字符(!@#$%^&*()_+-=)中的三种组成 确认密码 再次输入密码 备注说明 非必填,备注该账号的相关信息,便于后续账号管理。
说明:规格变更过程中,连接地址会有秒级别的连接闪断,建议在业务低谷期执行变更,并确保应用具备自动重连机制。
注意事项 云原生数据库 GaiaDB 集群创建后,为了保证数据安全,默认禁止所有 IP 通过。请用户重新设置白名单后再连接数据库。 目前白名单分组上限阈值为 50 个,所有分组内 IP 或者地址段累计不超过 1000 个。 支持添加多个IP,多个IP用英文逗号(,)分隔,%代表任意IP地址,支持CIDR模式(如10.10.0.0/16)。
字、下划线组成 账号类型 普通账号 可以通过控制台或者SQL语句创建和管理 一个集群可以创建多个普通账号,具体的数量与集群内核有关 需要手动给普通账号授予特定数据库的权限 普通账号不能创建和管理其他账号,也不能断开其他账号的连接 密码 长度为8~32个字符,由字母、数字和特殊字符(!
即,通过MySQL客户端连接数据库是交互式连接,通过JDBC连接数据库是非交互式连接。 原因分析 参数说明 interactive_timeout:服务器在关闭交互式连接前,客户端等待的秒数。 wait_timeout:服务器在关闭非交互式连接前,应用程序等待的秒数。
MySQL慢日志典型实践 概览 本文主要介绍慢日志明细和错误日志明细的使用方式。 需求场景 慢日志明细: 历史慢SQL实时统计,方便数据库管理员对慢查询语句进行分析,快速定位系统正在进行的性能问题。 错误日志明细: 开启和关闭MySQL服务的时间和服务运行中异常情况的统计,用于MySQL服务出现异常时,及时查找原因。
字段 填写指南 GaiaDB配置示例 数据源类型 目前支持MySQL、SQL Server两种数据源类型,根据你的数据库类型下拉选择(已支持的数据库版本:MySQL 5.6/5.7/8.0, SQL Server:2022) MySQL(GaiaDB 100%兼容MySQL) 数据库地址Host 您输入的数据源Host必须是公网地址,如果您的数据库不能通过公网访问 GaiaDB主地址或者集群地址的公网
根据数据库的类型(MySQL 5.7 或 MySQL 8.0),选择对应的参数模板,并点击 应用到集群 操作。 选择集群所在的地域并勾选对应的集群,在参数信息可以看到参数变化。 确认对所选择集群应用高性能模板。 方法二: 登录 GaiaDB 控制台 。 在 集群列表 找到目标集群,单击集群ID。 点击左侧列表中的 参数管理 。 点击 应用参数模板 。 在 模板名称 中选择系统高性能模板。