安装SDK工具包

运行环境

Java SDK工具包可在jdk1.6、jdk1.7、jdk1.8环境下运行。

方式一:使用Maven安装

在Maven的pom.xml文件中添加bce-java-sdk的依赖:

<dependency>
    <groupId>com.baidubce</groupId>
    <artifactId>bce-java-sdk</artifactId>
    <version>{version}</version>
</dependency>

其中,{version}为版本号,可以在SDK下载页面找到。

方式二:直接使用JAR包安装

步骤如下:

  1. 下载最新版Java SDK压缩工具包。

  2. 将下载的bce-java-sdk-{version}.zip解压后,复制到工程文件夹中。

  3. 在Eclipse右键“工程 -> Properties -> Java Build Path -> Add JARs”。

  4. 添加SDK工具包lib/bce-java-sdk-{version}.jar和第三方依赖工具包third-party/*.jar

其中,{version}为版本号,可以在SDK下载页面找到。

SDK目录结构

com.baidubce
├── auth                                        //BCE签名相关类
├── http                                        //BCE的Http通信相关类
├── internal                                    //SDK内部类
├── model                                       //BCE公用model类
├── services
│    └─ bcc                                 //BCC服务相关类
│       ├─ model                           //BCC内部model,如Request或Response
│       ├─ BccClient.class                 //BCC客户端入口类
│       └─ BccClientConfiguration.class    //针对BCC特有的HttpClient的配置
├── util                                      //BCE公用工具类
├── BceClientConfiguration.class              //对BCE的HttpClient的配置
├── BceClientException.class                  //BCE客户端的异常类
├── BceServiceException.class                 //与BCE服务端交互后的异常类
├── ErrorCode.class                           //BCE通用的错误码
└── Region.class                              //BCE提供服务的区域